• jacgopaint
    A few years ago I upgraded Twistedbrush and on doing so had this terrible thing happen were every time I changed a brush I would get a pop saying
    Unable to open C:\Program Files
    (x86)\Pixarra\TwistedBrush\artsets\shortcuts.pre file
    .. I asked for help off the old forum and though it took ages someone eventually came up with a solution ... I can't remember what that was, but what changed is that after doing it I would get a pop from windows before the twistedbrush was open asking if I want to allow twistedbrush to make changes on my pc... I would click yes and the program would open and I could open all the brushes I wanted with no problems.
    Untill yesterday that is when I decided to see if the newer version was worth buying the upgrade for, so I downloaded the trial, which unlike when I try other programs newer versions overwrote my old twistedbrush with the new version and to my horror the old problem was back. The old forum is gone so I can't check how I got it to work last time... hopefully someone can help again.. I've attached a video which I hope plays ok. In it you will see that every time I move my pointer and click on a brush I get the annoying pop up..every single time..... I tried to move the pointer slowly but it doesn't show me actually clicking on the brush (bottom left hand side).. just take my word for it, thats what brings the pop ...if you have sound on you'll also get the irritating sound.
    I'VE JUST..added a photo as it looks like you have to download the video to see it... I know I wouldn't want to download a video I knew nothing about... I've left it on incase someone knows how to make sure such things are safe to view and can view it...
    Untitled.f4v (18M)
    twisted brush fault (346K)
  • jacgopaint
    Can no one help....it's been a day and no reply....does this forum work....guess I'll have to use a support ticket...had hoped whoever help lest time would remember how to cure it.
  • Willabong
    Seems like you have a corrupted "Shortcuts pre" file?
    I would download the Pro version again and re-install it.
    If that does not solve the problem, then using the version you just downloaded, navigate to "C:\Program Files (x86)\Pixara\TwistedBrush\artsets and find the "Shortcuts.pre" file and use it to replace the one in your installed version.
    PS: Make sure you download the same version as your installed version of TB!
  • jacgopaint
    Hi Willabong
    Thanks for trying to help. I did the first thing you suggested, this had no effect other than of course to remove the trial version and install the version I bought a few years ago. I don't get your second suggestion....surely as I uninstalled the old version and now have installed the pro version again then that will be the only shortcuts.pre file... I now only have the one version on the pc so if I navigate to the file and find the shortcut.pre then I can't copy it and put it elsewhere.... am I making sense, I know what I mean... just don't know if you will.
    On top of that I noticed that even after I uninstalled it I still had a pixara folder in the C:\Program Files (x86) that contained all it's folders such as brushes and stuff.
    Hoping you can help some more.
  • jacgopaint
    Thought I'd just had a brain storm but it didn't work out.... I uninstalled again and this time went into the (x86)pixarra folder I told you about... in there I added 11 to the name of the shortcuts.pre file so that when I re-installed it would hopefully put a new one in there... this actually worked, there is a new shortcuts.pre file.... only it had no effect on the problem which is still there........
  • jacgopaint
    Fed up now... Just tried renaming the pixarra file in (x86) so that it would hopefully create a new one... it did... I opened the program which even after the unistall had saved the messy pic I was making and the problem is still there. I SOOOOOO WISH I could get on the old forum as the person who told me what to do last time had the correct solution and I'm sure it didn't involve all what I've been trying tonight... 1.25am and I'm giving up... may give up on this program altogether :(
  • Willabong
    I didn't make it clear: You need to uninstall all versions of Twisted Brush completely! Run the program uninstaller, then navigate to C:\Program Files (x86) and remove any Twisted Brush folders and delete them.
    Now you can re-install the program.
    If this does not work, then there is nothing else I can think of that you can do, as there is probably something else going on in your system causing the problem?
  • jacgopaint
    Hi again Willabong
    Will run through this again when I get back this evening, it may work, fingers crossed.
    With the 'cure' from the old forum it had something to do with making windows ask if I wanted to allow twistedbrush to make changes to my pc, i'd click yes, the program would then open and everything would work perfectly, no pop ups every time I change a brush or save my work. The windows pop up would come up every time I opened Twisted Brush.... do you know anyway of making Windows ask this question !!!
    Thanks for your continued help...it was nice to get a reply :)
  • Willabong
    That question is almost always asked when you begin installation of a program or program update! I can think of no other time you would be asked this?
  • jacgopaint
    Hi Willabong
    Yep I know that question only happens at installation and such..... thing is when I was told how to make it happen each time I opened Twistedbrush it solved my problem. I just did all the un-installing again and the problem is still there... some information must remain on the pc as even after getting rid of folders after the un-install it still loaded with the picture I was doing.
    Want I want now is to find out how to get that question asked when I load twistedbrush...sure something is wrong my end but that cured it last time .... I do so very very much wish I'd not wanted to try the new version, everything was fine before that :(
  • Spuddy
    anything in user account control that could help.turning setting right up to always notify but then that can't make TB make changes if it isn't going to I guess...sorry clutching at straws here
  • Willabong
    One other thing you could try is to download a copy of "Revo Uninstaller" from here:

    The free version will remove the program and also allow you to remove hidden entries and left over files relating to the program.
    This may remove the offending missed files?
  • Robyn
    Jacgopaint, sorry you are having such a bad time with this. Did you go to the main site and send a ticket to Ken? He has somehow missed seeing your problem I think, so that may bring it to his attention, unless he's ill, or away. Personally, I haven't downloaded a new version for quite a long time, so I can;t really say anything about it, and now I'm too scared to... O:) Robyn
  • Cecil DeBald
    It sounds to me like you have a User Account Control (UAC) issue. The popup that asks if you're sure you want to allow this program to make changes to your system" is a UAC popup. It happens when you have UAC enabled (that's the default setting when you install Windows - at least for Win10). You might have UAC disabled - to enable it, go to start and enter in the search box User Account Control; you should get an item "change UAC settings"; click that and move the control slider to "Always notify". click OK. Reboot, then run TB again, see if you get your popup message. If so, click and see if that makes everything work. I'm not sure why you're having the problem to begin with, something isn't right with your system, but if this lets you run TB, great! If it doesn't help, or if your UAC setting was already "Always Notify" then I don't know what it is. Do note that when you make this change to your UAC settings you might see the popup when you run other programs, it's a system-wide setting.

Add a Comment

Welcome to the Pixarra forum!

Feel free to look around, read posts and view images. Create an account to share some of your own thoughts or artwork, it's Free!